
No. Question Option1 Option2 Option3 Option4

1
Which option is used to create a new Google 

Form?
Insert → New Form Tools → Form Builder

Google Drive → New → 

Google Form
File → Create Form

2
Which of the following is a basic feature of 

Google Forms?

Auto-grading 

handwritten responses

Adding questions and 

sections

Creating video 

transitions
Running SQL queries

3 “Untitled form” refers to:
A form with hidden 

title

A form without a saved 

file name

A form imported from 

Excel

A form with no 

questions

4
Which question type allows users to choose 

multiple answers?
Short answer Multiple choice Checkbox Linear scale

5 Which type is best for long text responses? Dropdown Paragraph Multiple choice grid Date

6
Which question type supports adding images 

as options?
File upload Multiple choice Time Dropdown

7

Which question type is used to select only 

one choice from available choices in Google 

Form?

Paragraph Multiple choice Time Date

8
Which of the following is/are types of 

questions in Google Form?
Paragraph Multiple choice Time All of the Mentioned

9 Dynamic pivot helps in: Adding animations
Auto-generating 

summary graphs

Creating interactive 

pivot tables
Improving quiz scores

10 Dynamic pivot helps users analyze: YouTube videos Patterns and trends File types uploaded Device info

11 Linking responses to a sheet is done using: Settings → Auto save
Responses → Link to 

Sheets

Tools → Connect 

Workbook
Add-ons → Collector

12 “All-in-one book” means:
New sheet for each 

response

All responses in one 

sheet
Editing disabled Read-only mode
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13
In Google Sheets, what does the formula 

=SPLIT(A1, ",") do?

Converts the text in cell 

A1 to lowercase

Splits the text in cell A1 

into multiple cells based 

on commas

Joins text values with a 

comma separator

Converts the text in cell 

A1 to uppercase

14
Which of the following options is necessary to 

send a scanned response?
Gmail account Template Both a and b None of the above

15 Title case may be used for what purpose?
To change all letters to 

Uppercase

To change all first word 

to Uppercase in a 

sentence

To change it to a proper 

case
None of the above

16
What is the syntax for the multiplication 

function in Google Sheets?
 =MULTIPLY(A1, B1)  =A1 * B1  =PRODUCT(A1, B1)  =MULT(A1, B1)

17
What is the purpose of the LOWER function in 

Google Sheets?

Converts text to 

uppercase

Converts text to 

lowercase

Converts text to proper 

case

Converts text to title 

case

18
How would you use the SORT function to sort 

the values in column A in ascending order?

=SORT(A:A, 

ASCENDING)
=SORT(A:A, 1) =SORT(A:A, TRUE) =SORT(A:A)

19
How do you concatenate text values in 

Google Sheets?

Using the CONCAT 

function

Using the TEXTJOIN 

function
Using the SPLIT function

Using the 

CONCATENATE 

function

20

Which function would you use to find the 

highest sales figure from a range of cells in 

Google Sheets?

MIN MAX AVERAGE SUM

21
What is the syntax for the AVERAGE function 

in Google Sheets?
 =AVG(A1:A10)  =MEAN(A1:A10)  =AVERAGE(A1:A10)

 

=AVERAGEVALUE(A1:A

10)

22
Which function is used to convert text to 

uppercase in Google Sheets?
UPPER UCASE CONVERT_TO_UPPER TO_UPPER
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23
What is the syntax for the FILTER function in 

Google Sheets?

 =FILTER(range, 

condition)

=FILTER(range; 

condition)

=FILTER(range; 

condition; [optional 

arguments])

=FILTER(range, 

condition, [optional 

arguments])
24 Which menu in Google Sheets allows you to Data Format Insert Tools
25 Which function can you use to format a cell to TIMEFORMAT DURATION TIME TIMEVALUE
26 How do you protect a sheet in Google Sheets? Right-click on the sheet Click on "File" > "Protect Use the "Protect" Apply a password to 

27
How do you unfreeze rows or columns in 

Google Sheets?

Right-click on the 

frozen rows or columns 

and select "Unfreeze"

Click on "View" > 

"Unfreeze"

Use the "Format" menu 

to remove the freeze

There's no way to 

unfreeze rows or 

columns once they are 

frozen

28

Which function would you use to count the 

number of cells in a range that meet specific 

criteria in Google Sheets?

COUNT COUNTIF SUM AVERAGE

29
How do you add data fields to a pivot table in 

Google Sheets?

Drag and drop them 

into the appropriate 

areas of the pivot table

Click on "Insert" > "Data 

Field" and select the 

desired data field

Right-click on the pivot 

table and select "Add 

Data Field"

Type the data field 

names directly into the 

pivot table cells

30
How do you apply data validation to a range 

of cells in Google Sheets?

Right-click on the cells 

and select "Apply data 

validation"

Click on "Data" > "Data 

Validation" and define 

the validation criteria

Use a keyboard shortcut 

like Ctrl + D

There is no option for 

data validation in 

Google Sheets

31
Which of the following is the last step of the 

mail merge wizard?
Select the document  Edit the document

Personalize document     

                         
Save, Print or send
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32

You can use the ________ option to send 

email yourself first before sending it to others 

using mail merge.

Send Test email Gmail’s draft folder Send mail None of the above

33
What is the purpose of the VLOOKUP function 

in Google Sheets?

To perform arithmetic 

calculations

To search for a value in 

the first column of a 

range and return a 

value in the same row 

from a specified column

To filter data based on 

specific criteria

To concatenate text 

values

34

You can use the ________ option to send 

email yourself first before sending it to others 

using mail merge.

Send Test email Gmail’s draft folder Send mail None of the above

35
After creating the documents via Autocrat we 

can:

Save them in Google 

Drive
Opt to send as email Both None of the above

36
Canned response is the feature that can be 

used in which of the following?
GSheet MS Word Gmail GDoc

37
Change case is an add-on found in which of 

the following?
Gsheet GDoc Gmail All the above

38
Which of the following can be created using 

the Lucid chart?

Flowcharts and 

Diagrams

MS Powerpoint 

presentation
Google Slides None of the above

39
A diagram created using LucidChart cannot be 

exported to Google doc
TRUE FALSE True and False Sometimes

40
Which of the following button is used to 

delete unwanted fields from the address list?
New   Delete 

Customize & then 

Delete             
find
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41
How can you confirm if your screen is being 

recorded?

A yellow will appear in 

tab

A green icon will 

available in screen

A blue icon will appear 

in tab
None of the above

42 File upload question allows: Only images Any Drive-supported file Only PDFs Only Docs

43 Requirement for using 'File upload': Quiz mode enabled Google Sign-in required Paid account required Incognito mode

44 “Limit to 1 response” requires: Date question Google Sign-in Add-on File permission

45 To convert form into a quiz, enable: Quiz mode in Tools
Presentation → Quiz 

panel
Settings → Quiz

Responses → Auto 

grading

46
Which setting allows respondents to submit 

another response?
Shuffle question order Confirmation message Show progress bar

Show link to submit 

another response

47 “Shuffle question order” helps to: Prevent cheating Add images randomly Enable file upload Increase file size

48 SPLIT function is used to: Join text
Divide text using 

delimiter
Count characters Remove spaces

49 CONCAT function is used to: Add numbers Join multiple text strings Find text Sort text

50 LEFT function extracts characters from: End of text Beginning of text Middle of text Last word

51 RIGHT("Excel",2) returns: Ex El Cel Xc

52 Function to separate "A,B,C": CONCAT LEFT SPLIT PROPER

53 Extract last 3 characters: LEFT(text,3) RIGHT(text,3) MID(text,3) CONCAT(text,3)

54 CONCAT("Data ","Sheet") gives: DataSheet Data Sheet Data-Sheet Error

55 SPLIT(text," ") splits by: Comma Space Slash Number

56 SUM is used to: Count items Add numeric values Multiply numbers Sort data

57 Multiply values in Excel using: MULTIPLY(A1,B1) A1 * B1 PRODUCT(A1,B1) Both B & C

58 MIN function gives: Highest value Lowest value Average Count

59 MAX function gives: Highest value Lowest value Middle value None
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60 AVERAGE(10,20,30) equals: 15 20 25 30

61 Multiply entire range A1:A5: SUM(A1:A5) MULTIPLY(A1:A5) PRODUCT(A1:A5) COUNT(A1:A5)

62 LOWER("HELLO") returns: HELLO hello Hello HeLLo

63 Filter is used to: Sort data Hide non-matching data Format text Insert charts

64 Sort A–Z means: Ascending Descending Random Filtered

65 Remove duplicates found under: Insert Data Tools View

66 Best chart for percentage distribution: Bar chart Pie chart Line chart Area chart

67 Line chart is best for: Trends over time Category comparison Proportions Text formatting

68 Highlighting duplicates uses: Filters Conditional formatting Data validation Sort

69 Convert text to uppercase function: LOWER UPPER PROPER FORMAT

70 Currency formatting is available under: General Accounting Date Wrap

71 Duration between two times: Subtract end-start Add times Multiply times Average times

72 HH:MM represents: Days & Years Hours & Minutes Months Currency

73 Applying ₹ INR currency: Auto
Number → Currency → 

INR
Wrap text Merge cells

74 Sheet protection prevents: Viewing Editing Printing Sorting

75 Freezing row helps to: Delete row Keep header visible Hide header Duplicate row

76 Wrap text is used to: Shorten text Display full text in a cell Split text Delete text

77 To merge cells: Format → Wrap Data → Merge Format → Merge cells Insert → Merge

78 Indentation found under: Insert Tools Format → Alignment Data → Alignment

79 Justification means: Merging cells
Aligning 

left/right/center
Sorting data Cleaning data

80 COUNT function counts: Text only Numbers only All cell types Errors
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81 COUNTIF counts: Blank cells
Cells meeting a 

condition
Merged cells All text cells

82 Pivot table used to: Create layouts
Analyze and summarize 

data
Add charts Delete duplicates

83 VLOOKUP searches: Horizontally Vertically Both directions Alphabetically

84 Data validation is used to: Restrict data entry Add colors Format charts Protect sheet

85 Approximate match in VLOOKUP uses: TRUE FALSE BOTH NONE

86 Most used formula in marksheet totals: CONCAT SUM SPLIT MAX

87 Salary slip uses which formatting? Percentage Currency & Date Scientific Wrap text

88 Nimbus Screenshot tool is mainly used for: File compression
Capturing 

images/screens
Writing code Audio editing

89
Which Nimbus feature allows capturing long 

webpages?
Visible part only Selected area Scrolling capture Desktop crop

90
Where can you find the Nimbus option once 

you have added it to the Chrome browser?
Extension icon Editor window Applications All the above

91
Nimbus allows users to annotate screenshots 

using:
Antivirus tools Drawing & shapes tools Audio mixer Pivot table

92
How can you confirm if your screen is being 

recorded?

A yellow will appear in 

tab

A green icon will 

available in screen

A blue icon will appear 

in tab
None of the above

93 Nimbus Screen Recorder can record: Only audio Only webcam
Full screen, tab or 

window
Only PDF pages

94
Nimbus recorded videos are saved in which 

format?
.mp4 .txt .jpg .gif only

95 Nimbus lets you blur sensitive data using: Crop tool Blur/highlight tool Replace tool Animation tool
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96 Nimbus videos can include: 3D effects Webcam overlay QR scanner Device manager output

97 Nimbus extension can be installed from: BIOS settings Chrome Web Store VLC Media Player Android Emulator

98 Autocrat is primarily used for:
Sending WhatsApp 

messages

Automating document 

generation
Editing images

Running Excel 

functions

99 Autocrat works as an add-on in: Google Sheets Photoshop MS PowerPoint VLC Player

100
Autocrat generates output documents mainly 

in:
.mp3 .pdf .exe .wav

101
After creating the documents via Autocrat we 

can:

Save them in Google 

Drive
Opt to send as email Both None of the above

102
In Autocrat, the template for certificates is 

usually created in:
Google Docs/Slides Google Maps Notepad Chrome Browser

103
Autocrat uses ______ to fill certificates or 

bulk emails.
Filters Merge fields Formatting tools Graphics

104
Autocrat saves generated files automatically 

in:
Recycle Bin Google Drive USB Folder BIOS Memory

105 Autocrat “Job” refers to: Antivirus process
Automation instruction 

for merging
Video rendering Audio mixing

106 Autocrat can run automatically using: Google Sheets triggers Windows scheduler VLC settings Browser cache

107 Adobe DocuSign is mainly used for: Creating presentations E-signing documents Editing videos Designing logos

108
Which file type is commonly used for e-

signing in DocuSign?
.mp3 .pdf .exe .wav
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109
DocuSign sends documents to recipients 

through:
Bluetooth Email USB sharing QR code

110 DocuSign signatures are considered: Illegal Temporary Legally valid Not recognized

111 To sign a document in DocuSign, users must: Upload the document Install antivirus Edit using Photoshop Use a barcode

112
DocuSign allows adding which elements to 

documents?
Music tracks Signature fields Animation effects Coding scripts

113
Authentication in DocuSign can be done 

using:
OTP / Email verification Game login Network ping Device BIOS

114 DocuSign dashboard shows: RAM usage
Signing status & 

progress
Audio playlist YouTube history

115 Google Meet is mainly used for: Photo editing Video conferencing Coding File compression

116
Which feature in Google Meet suppresses 

background noise?
Noise cancellation Auto text Screen recorder Dark mode

117 To share screen in Google Meet, you use: Present Now Insert Screen Upload Window Share Camera

118 Google Meet sessions require: Internet connection Blu-ray disc Antivirus software Python installation

119 Which layout shows all participants together? Spotlight Auto Tiled Mini view

120 Host controls include: Turning off lights Removing participants Editing videos Programming

121
Attendance in Google Meet can be tracked 

using:
Add-ons/Extensions BIOS Calculator Task Manager

122 Background change feature in Meet allows: Adding games
Blurring or replacing 

background
Rewriting code Installing apps

123 Zoom is used primarily for: Video conferencing Car diagnostics Game development Audio mixing

124 Zoom feature “Breakout Rooms” is used for: Background blur
Splitting participants 

into groups
Increasing bandwidth Adding music
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125 Zoom meeting recordings are stored in: Control Panel
Zoom cloud or local 

device
YouTube Paint

126 The security feature to lock a meeting is: Meeting Guard Lock Meeting Close Session Block Camera

127 Host can mute all participants using: Mute All Voice Filter Audio Cut Sound Lock

128 Zoom waiting room feature allows: Editing documents
Approving participants 

before joining
Installing apps Changing themes

129 Virtual background in Zoom allows users to: Change wallpaper
Change or blur their 

background
Increase volume Install plugins

130 Zoom chat allows:
Sending files & 

messages
Editing videos Making invoices Designing flowcharts

131 SMS is transmitted using which protocol? SMTP HTTP/HTTPS SMPP POP3

132 SMPP stands for:
Short Message Peer-to-

Peer

Simple Messaging 

Protocol Program

Smart Mobile Protocol 

Platform

System Message 

Process Pack

133 Bulk SMS service is mainly used for: File storage Mass communication Antivirus scanning Video editing

134
Which service allows sending large-volume 

automated emails?
MS Paint

Customized Email 

Service
VLC Player Chrome Extension

135 WhatsApp bulk messaging requires: Robotics API-based integration Offline mode Calculator

136 SMTP is a protocol used for: Email communication SMS delivery Image compression Encryption

137 Bulk SMS gateways mainly use: Manual typing Automated API requests USB sharing Bluetooth connection

138 Customized SMS service allows:
Personalized message 

templates
Movie editing Hardware upgrade Software installation

139 SMS stands for Same Message Simple Short Message Service Simple Message Service Service Message Short
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Unit-1: Data Assemblage Skill - Google Form  

 

Google Forms is a free, web-based tool for creating surveys, quizzes, and data collection forms. It is a part 

of the Google Workspace suite. Google Forms integrates with Google Sheets for data analysis.  

Key Features 

• Question Types: Supports multiple choice, checkboxes, dropdowns, linear scales, and file uploads. 

• AI Integration: Features AI to summarize responses and detect data entry errors. 

• Customization: Users can personalize forms with brand colors, custom fonts, and header images. 

• Quiz Mode: Allows auto-grading, answer keys, and instant feedback. 

• Logic Branching: Enables conditional logic to skip sections or show specific questions. 

• Draft Saving: Form progress is automatically saved for 30 days if respondents are signed into a 

Google account.  

How to Use Google Forms 

1. Access: Visit forms.google.com or create a new form directly from Google Drive or Google Sheets. 

2. Creation: Start with a Blank form or choose from the Template Gallery (e.g., RSVP, job application). 

3. Editing: Click the "+" icon to add questions and the "eye" icon to preview your form's flow. 

4. Sharing: Click Send to distribute the form via email, a direct link, or by embedding it on a website. 

5. Analyzing: View responses in the Responses tab or click the Sheets icon to export data to Google 

Sheets for advanced filtering.  

Security and Compliance 

Google Forms is secure by default, using encryption in transit and at rest. It supports various regulatory 

compliance needs and allows owners to restrict access to specific email domains or require sign-ins.  

 

Creating a Google Form is a straightforward process that allows you to collect data, conduct surveys, or 

build quizzes for free. Below is a step-by-step guide for 2025.  

1. Create a New Form 

There are several ways to start a new form from your browser: 

• Direct Link: Go to forms.google.com and click Blank form. 

• Google Drive: Open Google Drive, click + New, and select Google Forms. 
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• Quick Shortcut: Type forms.new into your browser's address bar to instantly create a new blank 

form. 

• Templates: Use the Template Gallery on the Forms homepage to choose pre-designed layouts like 

event registrations, party invites, or job applications.  

2. Design and Add Questions 

Once your form is open, you can begin structuring your content:  

• Title and Description: Click on Untitled Form to give it a name and add a description for your 

respondents. 

• Add Questions: Click the (+) Add question icon in the floating toolbar on the right. 

• Question Types: Choose the response format from the dropdown menu (e.g., Short answer, 

Multiple choice, Checkboxes, Dropdown, Linear scale, or File upload). 

• Mandatory Fields: Toggle the Required switch at the bottom of a question to ensure respondents 

don't skip it. 

• Sections: Use the (=) Add section icon to break longer forms into multiple pages.  

3. Customize the Look 

Make your form match your brand or style: 

• Themes: Click the Customize Theme (palette) icon at the top right to change fonts, text sizes, and 

theme colors. 

• Header Image: Under the theme settings, click Choose image to upload your own logo or pick a 

header from Google’s library. 

• Media: You can add standalone images or YouTube videos to your form by clicking the Add 

image or Add video icons in the right-hand toolbar.  

4. Adjust Settings and Preview 

Before sending, check your configuration: 

• Preview: Click the Eye icon at the top right to see how the form will look to respondents. 

• Quizzes: In the Settings tab, toggle Make this a quiz to assign point values and correct answers. 

• Access Control: Under Settings > Responses, you can choose to collect email addresses, limit users 

to one response, or allow them to edit after submitting.  

5. Send and Analyze Responses 

• Distribute: Click the Send button to share the form via email, a direct link, or by embedding it into a 

website. 
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• View Results: Click the Responses tab to see real-time charts and summaries of your data. 

• Export to Sheets: Click the Link to Sheets icon (green spreadsheet logo) to automatically send all 

responses to a Google Sheet for deeper analysis 

6. Dynamic pivot enabling 

To enable dynamic pivoting for Google Form data, link the form to Google Sheets, then create a pivot table 

in a new sheet using the entire data range (e.g., A:C or A:Z), not just specific rows, so it automatically updates 

as new responses come in, providing a real-time summary. For true in-form dynamic fields (like conditional 

questions), you'll need Google Apps Script or add-ons, as standard forms lack this built-in logic, but the Sheet 

pivot is the most common "dynamic pivot" solution 

Step 1: Link Form to Google Sheets (If not already linked) 

1. Open your Google Form, go to the Responses tab. 

2. Click the Google Sheets icon (View in Sheets) to link or create a spreadsheet.  

Step 2: Create the Dynamic Pivot Table in Google Sheets 

1. In the linked Google Sheet, click on the Insert menu, then select Pivot table. 

2. In the "Create pivot table" dialog, ensure the Data range covers all columns 

(e.g., Sheet1!A:C or Sheet1!A:Z) and select New sheet, then click Create. 

3. Crucially, in the Pivot table editor (right sidebar), set your Rows, Columns, Values, and Filters. For 

example, use Timestamp for Rows, a specific question's column for Values (e.g., "What's your favorite 

color?"), and set the Summarize by to COUNTA to see counts.  

Step 3: How it becomes dynamic 

• When new form responses arrive, they are added to the bottom of the source data sheet. 

• Because your pivot table's data range is set to the entire column (e.g., A:C), it automatically includes 

the new data, and the pivot table refreshes to show the updated totals, counts, or summaries.  

7. Document Upload 

To add document uploads in Google Forms, create a new question, select the File upload option from the 

dropdown, click Continue, and then customize settings like file types, number, and size, remembering that 

respondents must sign in to a Google account to upload files, with files automatically saved to your Google 

Drive.  

8. Other Setting 

The settings for managing responses, converting a form to a quiz, and presentation options, are found under 

the "Settings" tab in Google Forms.  

The term you are using, "Reposes Setting," appears to be a slight misspelling; the correct term in Google 

Forms is the "Responses" section.  



Page 4 of 44 

Here is how to access and manage those settings: 

Accessing the Settings Tab 

1. Open your form in Google Forms. 

2. At the top of the form editor, you will see three main tabs: Questions, Responses, and Settings. Click 

on the Settings tab.  

Responses Settings 

Within the "Settings" tab, the "Responses" section (sometimes an independent tab in the older UI, but now 

a section under "Settings" in the new UI) allows you to control how responses are collected and managed.  

• Collect email addresses: You can choose to automatically collect respondents' email addresses. 

• Limit to 1 response: This prevents users from submitting the form more than once (requires 

respondents to sign in to a Google account). 

• Allow response editing: You can decide if respondents can change their answers after submitting the 

form. 

• Response receipts: Send a copy of their responses to the people who fill out the form.  

Convert to Quiz (Quizzes Setting) 

To convert your form into a self-grading quiz: 

1. Navigate to the Settings tab. 

2. Find the "Quizzes" section and turn on the toggle for "Make this a quiz". 

3. Once enabled, you can configure options such as: 

• Release grades: Choose to release scores immediately after submission or after manual 

review. 

• Respondent settings: Control what respondents can see after they submit (e.g., missed 

questions, correct answers, point values). 

• Point values: Set a default point value for new questions.  

Presentation Setting 

The "Presentation" section controls the experience for the person filling out the form.  

• Show progress bar: Displays a bar at the bottom of the form to indicate how close the respondent is 

to finishing. 

• Shuffle question order: Randomizes the order of questions for each person filling out the form, which 

can help prevent cheating in quizzes. 

• Confirmation message: Customize the message users see after they submit their form. 

• Show link to submit another response: Allows users to fill out the form multiple times if "Limit to 1 

response" is disabled 

 

 

 



Page 5 of 44 

Unit-2: Worksheet Management Skill – Google Sheet / Adv. Excel 
 

SUM 
In Google Sheets, you can use the SUM formula to add up a range of cells. The 
syntax is simple: = SUM(range). 

For example, if you want to sum up the values in cells A1 to A10, you would use =SUM(A1:A10) 
 

Multiply 
To multiply values in Google Sheets, you can use the PRODUCT formula. 
The syntax is similar to SUM: =PRODUCT(range) or =PRODUCT(value1, value2, ...). 
For instance, to multiply the values in cells A1 and B1, you would use =PRODUCT(A1, B1) 

SPLIT function 
In Google Sheets, you can use the SPLIT function to split text into separate cells based on a delimiter. The 
syntax is: 

=SPLIT(text, delimiter, [split_by_each], [remove_empty_text]) 
- text: The text you want to split. 
- delimiter: The character or string that separates each part of the text. 

- [split_by_each] (optional): If set to TRUE, it splits the text by each character. If set to FALSE or 
omitted, it splits by the entire delimiter. 

- [remove_empty_text] (optional): If set to TRUE, it removes empty text entries from the result. If set 
to FALSE or omitted, it includes empty text entries. 

For example, if you have the text "apple,banana,orange" in cell A1 and you want to split it by commas, you 
would use =SPLIT(A1, ","). This would separate "apple", "banana", and "orange" into three adjacent cells. 

SPLIT function: 
 

Divides text around a specified character or string, and puts each fragment into a separate cell in the row. 

Examples: 
cell_context delimiter Result Formula 

Google o G gle   =SPLIT(A2, "o") 

Google oo G gle   =SPLIT(A3, "oo") 

DmOnCmSn mn D O C S =SPLIT(A4, "mn") 

DmOnCmSn mn D O C S =SPLIT(A5, "mn", TRUE) 

DmOnCmSn mn DmOnCmSn    =SPLIT(A6, "mn", FALSE) 
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Sample Usage: 
SPLIT("1,2,3", ",") 
SPLIT("Alas, poor Yorick"," ") SPLIT(A1, 
",") 

Syntax: 
SPLIT(text, delimiter, [split_by_each], [remove_empty_text]) 
• text - The text to divide. 
• delimiter - The character or characters to use to split text. 
• By default, each character in delimiter is considered individually, e.g. if delimiter is "the", then 

text is divided around the characters "t", "h", and "e". Set split_by_each to FALSE to turn off this 
behavior. 

• split_by_each - [ OPTIONAL - TRUE by default ] - Whether or not to divide text around each character 
contained in delimiter. 

• remove_empty_text - [ OPTIONAL - TRUE by default ] - Whether or not to remove empty text messages 
from the split results. The default behavior is to treat consecutive delimiters as one (if TRUE). If 
FALSE, empty cells values are added between consecutive delimiters. 

RIGHT function 
In Google Sheets, the RIGHT function extracts a specified number of characters from the end (right side) 
of a text string. The syntax for the RIGHT function is: 

=RIGHT(text, [num_chars]) 

- text: The text string from which you want to extract characters. 
- [num_chars]: The number of characters you want to extract from the end of the text string. If 

omitted, it defaults to 1. 

For example, if you have the text "Hello" in cell A1 and you want to extract the last three characters, you 
would use =RIGHT(A1, 3), which would result in "llo". 

RIGHT 

 
Returns a substring from the end of a specified string. 

Sample Usage 
RIGHT(A2,2) 
RIGHT("lorem ipsum") 

Syntax 
RIGHT(string, [number_of_characters]) 
• string - The string from which the right portion will be returned. 
• number_of_characters - [ OPTIONAL - 1 by default ] - The number of characters to return from the 

right side of string. 
Examples 

Result Formula 

ocs =RIGHT("Google Docs", 3) 

e =RIGHT("Google") 
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LEFT function 
In Google Sheets, the LEFT function extracts a specified number of characters from the beginning (left 
side) of a text string. The syntax for the LEFT function is: 
=LEFT(text, [num_chars]) 
 

- text: The text string from which you want to extract characters. 
- [num_chars]: The number of characters you want to extract from the beginning of the text string. If 

omitted, it defaults to 1. 

For example, if you have the text "Hello" in cell A1 and you want to extract the first three characters, you 
would use =LEFT(A1, 3), which would result in "Hel". 
LEFT 
Returns a substring from the beginning of a specified string. 

Sample Usage 
LEFT(A2,2) 
LEFT("lorem ipsum") 

Syntax 
LEFT(string, [number_of_characters]) 
• string - The string from which the left portion will be returned. 
• number_of_characters - [ OPTIONAL - 1 by default ] - The number of characters to return from the 

left side of string. 
 

 

Result Formula 

Goo =LEFT("Google Docs", 3) 

G =LEFT("Google") 

 
Min Function 
In Google Sheets, the MIN function is used to find the minimum value in a range of cells or a list of values. 
The syntax for the MIN function is: 

=MIN(value1, [value2, ...]) 
You can provide multiple values or cell references as arguments, and the function will return the 
smallest value among them. 
 
For example, if you want to find the minimum value among the numbers in cells A1 to A10, you would use 
=MIN(A1:A10). If you want to find the minimum value among specific numbers, you would use =MIN(5, 
10, 15) which would return 5. 
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MAX function 
In Google Sheets, the MAX function is used to find the maximum value in a range of cells or a list of values. 
The syntax for the MAX function is: 

=MAX(value1, [value2, ...]) 
 
You can provide multiple values or cell references as arguments, and the function will return the largest 
value among them. 

For example, if you want to find the maximum value among the numbers in cells A1 to A10, you would use 
=MAX(A1:A10). If you want to find the maximum value among specific numbers, you would use =MAX(5, 
10, 15) which would return 15. 
 

AVERAGE function 
In Google Sheets, the AVERAGE function calculates the average (arithmetic mean) of a range of cells or a 
list of values. The syntax for the AVERAGE function is: 
 
=AVERAGE(value1, [value2, ...]) 

You can provide multiple values or cell references as arguments, and the function will return the average 
value. 
 
For example, if you want to find the average of the numbers in cells A1 to A10, you would use 
=AVERAGE(A1:A10). If you want to find the average of specific numbers, you would use =AVERAGE(5, 10, 
15) which would return 10. 

Change the case 
In Google Sheets, you can change the case of text using three different functions: UPPER, LOWER, and 
PROPER. 
 

1. UPPER: Converts all letters in a text string to uppercase. 
Example: =UPPER("hello") would return "HELLO". 

 
2. LOWER: Converts all letters in a text string to lowercase. 

Example: =LOWER("Hello") would return "hello". 
 

3. PROPER: Capitalizes the first letter of each word in a text string and converts all other letters to 
lowercase. 

Example: =PROPER("hello world") would return "Hello World". 
 
These functions are useful when you need to standardize the case of text data in your Google Sheets. 

FILTER 
In Google Sheets, the FILTER function is used to retrieve rows or columns that meet specified criteria from 
a range. Here are the steps to use the FILTER function along with examples: 
 
### Steps to use the FILTER function: 
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1. *Select a cell where you want the filtered results to appear*: Choose a cell where you want the 
filtered data to be displayed. 

2. *Enter the FILTER function*: Type =FILTER( into the selected cell to start the function. 
 

3. *Specify the range*: Enter the range of data from which you want to filter rows or columns. 

4. *Define the condition(s)*: Specify the condition(s) that the rows or columns must meet to be 
included in the filtered results. 

5. *Close the function and press Enter*: Close the parentheses and press Enter to apply the filter and 
display the results. 

 
Example 1: Filter rows based on a single condition 

Let's say you have a dataset in cells A1:B10 containing names and corresponding ages. You want to filter 
out the rows where the age is greater than or equal to 30. 

1. Select a cell where you want the filtered results to appear, for example, cell D1. 
2. Enter the following FILTER function: =FILTER(A1:B10, B1:B10 >= 30). 
3. Press Enter. 

 
This will display only the rows where the age is greater than or equal to 30. 

Example 2: Filter rows based on multiple conditions 

Let's say you have a dataset in cells A1:C10 containing names, ages, and genders. You want to filter out 
the rows where the age is greater than or equal to 30 and the gender is "Male". 

1. Select a cell where you want the filtered results to appear, for example, cell E1. 
2. Enter the following FILTER function: =FILTER(A1:C10, (B1:B10 >= 30) * (C1:C10 = "Male")). 
3. Press Enter. 

This will display only the rows where the age is greater than or equal to 30 and the gender is "Male". 
 
Using the FILTER function, you can dynamically extract data from a range based on specified criteria, 
making it a powerful tool for data analysis and manipulation in Google Sheets. 

In Google Sheets, you can sort data in ascending or descending order using the SORT function or the 
built-in sorting feature. 

SORT function: 
 
The SORT function allows you to sort a range of data based on one or more columns. The syntax for the 
SORT function is as follows: 
 
=SORT(range, sort_column, is_ascending, [sort_column2, is_ascending2, ...]) 
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- range: The range of data you want to sort. 
- sort_column: The column number (or array of column numbers) by which to sort. 
- is_ascending: TRUE for ascending order, FALSE for descending order. 
- [sort_column2, is_ascending2, ...] (optional): Additional columns and sorting directions. 

 
Using the built-in sorting feature: 

1. Select the range of data you want to sort. 
2. Go to the "Data" menu. 
3. Click on "Sort range..." 
4. Choose the column you want to sort by and the sorting order (ascending or descending). 
5. Click "Sort". 

Example: 

Let's say you have a dataset in cells A1:C10 containing names, ages, and salaries, and you want to sort 
the data based on the ages in ascending order: 

Using SORT function: 

=SORT(A1:C10, 2, TRUE) 
 
Using built-in sorting feature: 

1. Select the range A1:C10. 
2. Go to the "Data" menu. 
3. Click on "Sort range..." 
4. Choose column B (ages) and select "Ascending". 
5. Click "Sort". 

Both methods will sort the data based on the ages in ascending order, arranging the rows 
accordingly. 
To find and remove duplicates in Google Sheets, you can use the built-in features or formulas. 

Find Duplicates: 
1. *Using Conditional Formatting*: 

- Select the range of cells where you want to find duplicates. 
- Go to the "Format" menu. 
- Choose "Conditional formatting." 
- Under the "Format cells if" dropdown, select "Custom formula is." 
- Enter the formula =COUNTIF(A:A, A1)>1 (replace A:A with your actual range). 
- Set the format to highlight the duplicates. 
- Click "Done." 

2. *Using the COUNTIF Function*: 
- Insert a new column next to your data. 
- In the first cell of the new column, enter the formula =COUNTIF(A:A, A1) (replace A:A with your 

actual range). 
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- Drag the formula down to apply it to all cells in the column. 
- Filter the column by values greater than 1 to display duplicates. 

Remove Duplicates: 
 

1. *Using the Built-in Feature*: 
- Select the range of cells containing your data. 
- Go to the "Data" menu. 
- Click on "Remove duplicates." 
- Choose the columns you want to check for duplicates. 
- Click "Remove duplicates." 

2. *Using Formulas*: 
- Insert a new column next to your data. 
- In the first cell of the new column, enter the formula =UNIQUE(A:A) (replace A:A with your actual 

range). 

- Drag the formula down to apply it to all cells in the column. 
- This will create a new column with unique values. 
- You can copy these values and paste them over your original data if needed. 

Charts 
These methods allow you to easily identify and manage duplicates in your Google Sheets data. 
In Google Sheets, you can create various types of charts and graphs to visualize your data. Here's how 
to create a chart: 

1. *Select Data*: Highlight the data range you want to include in your chart. 
 

2. *Insert Chart*: 
- Go to the "Insert" menu. 
- Click on "Chart." 
- Alternatively, you can also click on the chart icon in the toolbar. 

3. *Choose Chart Type*: 
- In the Chart Editor that appears on the right, choose the type of chart you want to create (e.g., 

Column chart, Line chart, Pie chart, etc.). 
 

4. *Customize Chart*: 
- Customize the chart style, colors, and other settings as needed. 
- You can also adjust the chart title, axis labels, and legend. 

 
5. *Preview and Insert*: 

- Once you're satisfied with the chart settings, click "Insert" to add… 
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Graph 
To create a graph in Google Sheets, you can follow these steps: 
 

1. *Select Data*: Highlight the data range you want to include in your graph, including the column or 
row headers. 

 
2. *Insert Chart*: 

- Go to the "Insert" menu. 
- Click on "Chart." 
- Alternatively, you can also click on the chart icon in the toolbar. 

3. *Choose Chart Type*: 
- In the Chart Editor that appears on the right, choose the type of graph you want to create (e.g., 

Line graph, Bar graph, Scatter plot, etc.). 
 

4. *Customize Graph*: 
- Customize the graph style, colors, and other settings as needed. 
- You can adjust the graph title, axis labels, legend, and data series. 

5. *Preview and Insert*: 
- Once you're satisfied with the graph settings, click "Insert" to add the graph to your Google 

Sheets. 
 
Example Graph Types: 
 

1. *Line Graph*: Suitable for showing trends or changes over time. 

2. *Bar Graph*: Ideal for comparing values across different categories. 

3. *Scatter Plot*: Displays individual data points as dots, useful for showing relationships between two 
variables. 

4. *Histogram*: Represents the distribution of numerical data. 
 

5. *Pie Chart*: Displays parts of a whole, suitable for showing percentages. 
 
Calculate time durations 
In Google Sheets, you can calculate time durations using a combination of formulas and formatting. Here 
are the steps to calculate and display time durations: 

1. *Enter Start and End Times*: In two separate cells, enter the start time and end time. For example, in 
cell A1, you might enter the start time as "9:00 AM" and in cell B1, you might enter the end time as 
"10:30 AM". 

2. *Calculate Duration*: In another cell, you can subtract the start time from the end time to calculate 
the duration. For example, if the start time is in cell A1 and the end time is in cell B1, you can use the 
formula =B1-A1. 
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3. *Format as Duration*: After calculating the duration, you can format the cell to display the result as a 
duration. Right-click on the cell with the duration, select "Format cells...", then choose "Duration" 
under the "Category" section. You can also specify the desired time units (hours, minutes, seconds) 
and the display format. 

 
4. *Custom Formatting (Optional)*: You can further customize the formatting of the duration by right-

clicking on the cell, selecting "Format cells...", and choosing "Custom" under the "Category" section. 
From there, you can enter a custom format code to display the duration in a specific format. 

Currency: 
 
In Google Sheets, you can easily format numbers as currency using the built-in formatting options. Here's 
how to do it: 
 
Formatting as Currency: 

1. *Select the Cell(s)*: Highlight the cells or range of cells that you want to format as currency. 
 

2. *Go to Format Options*: 
- You can either right-click and select "Format cells..." or go to the "Format" menu and choose 

"Number" > "More formats" > "Number" > "Currency". 

3. *Choose Currency Format*: 
- In the Format sidebar that appears, click on the dropdown menu next to "Currency". 
- Select the desired currency symbol from the list (e.g., Dollar, Euro, Pound, etc.). 

4. *Set Additional Options (Optional)*: 
- You can adjust the number of decimal places, choose a different currency symbol position, or 

apply custom formatting if needed. 

5. *Apply the Formatting*: 
- Click "Apply" or simply close the Format sidebar to apply the currency formatting to the selected 

cells. 
Example: 
 
Let's say you have a column of numbers representing prices or amounts, and you want to format them 
as currency. 
 

1. *Select the Cell(s)*: Highlight the column of numbers you want to format as currency. 

2. *Go to Format Options*: 
- Right-click and select "Format cells..." or go to the "Format" menu and choose "Number" > "More 

formats" > "Number" > "Currency". 
 

3. *Choose Currency Format*: 
- In the Format sidebar, select the desired currency symbol from the dropdown menu (e.g., Dollar 

symbol "$"). 
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4. *Set Additional Options (Optional)*: 
- Adjust the decimal places or choose a different currency symbol position if needed. 

5. *Apply the Formatting*: 
- Click "Apply" or close the Format sidebar to apply the currency formatting to the selected column 

of numbers. 

After applying the currency formatting, the numbers will be displayed with the chosen currency symbol 
and format, making it easier to read and understand the monetary values in your Google Sheets. 
In Google Sheets, you can protect sheets to prevent accidental or unauthorized changes to the content, 
formatting, and structure of your spreadsheet. Here's how to protect sheets: 

Protecting Sheets: 
 

1. *Open Google Sheets*: Open the Google Sheets spreadsheet that you want to protect. 
 

2. *Select the Sheet(s)*: Click on the sheet tab at the bottom to select the sheet(s) you want to protect. 
You can select multiple sheets by holding down the Ctrl (Cmd on Mac) key while clicking on the sheet 
tabs. 

3. *Go to the "Data" Menu*: Once you've selected the sheet(s), go to the "Data" menu at the top. 
 

4. *Choose "Protect Sheet..."*: In the "Data" menu, hover over "Protected sheets and ranges" and 
select "Protect sheet...". 

5. *Set Permissions*: In the "Protect sheet" dialog box that appears, you can set permissions for the 
protected sheet. You can choose who can edit the protected range and who can view it. You can also 
add a description for the protected range. 

 
6. *Optional: Add a Warning*: You can add a warning message that will be displayed to users who try to 

edit the protected range. 
 

7. *Click "Set Permissions"*: After setting the permissions and optional warning message, click "Set 
Permissions" to protect the sheet. 

Freezing Rows: 
 
1. *Open Google Sheets*: Open the Google Sheets spreadsheet where you want to freeze rows or 

columns. 

2. *Select Row(s) to Freeze*: Click on the row number(s) below the row(s) you want to freeze. For 
example, if you want to freeze the first two rows, click on the number "3" (indicating row 3). 

 
3. *Go to the "View" Menu*: Once you've selected the row(s), go to the "View" menu at the top. 
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4. *Choose "Freeze"*: In the "View" menu, hover over "Freeze" and select "Up to current row" to 
freeze the selected row(s). Alternatively, you can choose "1 row" to freeze just the top row. 

### Freezing Columns: 
 
1. *Open Google Sheets*: Open the Google Sheets spreadsheet where you want to freeze rows or 

columns. 

2. *Select Column(s) to Freeze*: Click on the column letter(s) to the right of the column(s) you want to 
freeze. For example, if you want to freeze the first two columns, click on the letter "C" (indicating 
column C). 

 
3. *Go to the "View" Menu*: Once you've selected the column(s), go to the "View" menu at the top. 

 
4. *Choose "Freeze"*: In the "View" menu, hover over "Freeze" and select "Up to current column" to 

freeze the selected column(s). Alternatively, you can choose "1 column" to freeze just the leftmost 
column. 

Example: 

Let's say you have a spreadsheet with a large dataset, and you want to freeze the first row and the first 
two columns to keep them visible while scrolling through the rest of the data. 
 

1. Click on the row number "2" to select the first row. 
2. Go to the "View" menu and choose "Freeze" > "1 row" to freeze the first row. 
3. Click on the column letter "C" to select the first two columns. 
4. Go to the "View" menu and choose "Freeze" > "1 column" to freeze the first two columns. 

Now, as you scroll through your spreadsheet, the first row and the first two columns will remain visible, 
making it easier to reference headers or other important information while navigating through your data. 

Text Wrapping 
To wrap text within a cell in Google Sheets, you can follow these steps: 
 

1. *Select Cell(s)*: Click on the cell(s) containing the text you want to wrap. 
 

2. *Go to the "Format" Menu*: Once you've selected the cell(s), navigate to the "Format" menu at the 
top of the Google Sheets interface. 

3. *Choose "Text Wrapping"*: In the "Format" menu, hover over "Text wrapping" and select "Wrap." 

Example: 
Let's say you have a long text string in cell A1 that you want to wrap: 
 

1. Click on cell A1 to select it. 
2. Go to the "Format" menu. 
3. Choose "Text wrapping" and select "Wrap." 
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Now, if the text in cell A1 is longer than the width of the cell, it will automatically wrap to fit within the 
cell boundaries. This makes it easier to read long text strings without adjusting column widths or losing 
any content. 
 
Wrapping text within cells is particularly useful when dealing with descriptions, notes, or any other text 
content that may be longer than the width of a cell. 

Merging Cells: 
 
In Google Sheets, you can merge cells to combine multiple adjacent cells into a single larger cell. 
Here's how to merge cells: 
 

1. *Select Cells*: Click and drag to select the range of cells you want to merge. Note that you can only 
merge adjacent cells in the same row or column. 

2. *Go to the "Format" Menu*: Once you've selected the cells, go to the "Format" menu at the top. 
 

3. *Choose "Merge Cells"*: In the "Format" menu, hover over "Merge cells" and select either "Merge 
all" to merge the selected cells into a single larger cell, or "Merge horizontally" or "Merge vertically" 
to merge the cells in the selected direction. 

 
Example: 
 
Let's say you have data in cells A1:B1 that you want to merge into a single cell: 

1. Click and drag to select cells A1:B1. 
2. Go to the "Format" menu. 

3. Choose "Merge cells" and select "Merge horizontally" to merge cells A1 and B1 into a single larger 
cell. 

Now, the content from both cells A1 and B1 will be combined into a single larger cell spanning across both 
columns. You'll notice that the cell border will disappear to indicate that the cells have been merged. 
 
Merging cells can be useful for creating headings, labels, or titles that span multiple columns or rows, 
enhancing the visual appearance and organization of your Google Sheets. 

Justification/Alignment : 
In Google Sheets, you can adjust the horizontal and vertical alignment of cell content using the justification 
options. Here's how to do it: 

Horizontal Alignment: 
 

1. *Select Cell(s)*: Click on the cell(s) whose content alignment you want to adjust. 
 

2. *Go to the "Format" Menu*: Once you've selected the cell(s), go to the "Format" menu at the top. 
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3. *Choose "Text Alignment"*: In the "Format" menu, hover over "Text alignment" to reveal the 
horizontal alignment options: Left, Center, Right, and Justify. 

4. *Select Alignment Option*: Choose the desired horizontal alignment option based on how you 
want the content to be aligned within the cell(s). 

 
Vertical Alignment: 

1. *Select Cell(s)*: Click on the cell(s) whose content alignment you want to adjust. 
 

2. *Go to the "Format" Menu*: Once you've selected the cell(s), go to the "Format" menu at the top. 
 

3. *Choose "Text Alignment"*: In the "Format" menu, hover over "Text alignment" to reveal the 
vertical alignment options: Top, Middle, and Bottom. 

4. *Select Alignment Option*: Choose the desired vertical alignment option based on how you want the 
content to be aligned within the cell(s). 

Example: 

Let's say you want to horizontally align the content of cell A1 to the center and vertically align it to the 
middle: 
 

1. Click on cell A1 to select it. 
2. Go to the "Format" menu. 
3. Choose "Text alignment" and select "Center" for horizontal alignment and "Middle" for vertical 
alignment. 

Now, the content of cell A1 will be horizontally centered and vertically aligned to the middle within the 
cell. 
 
Adjusting text alignment helps improve the readability and presentation of your Google Sheets, 
especially when working with large amounts of data or creating formatted reports and documents. 

Indention: 
In Google Sheets, you can indent cell content to create visual hierarchy and organization within your 
spreadsheet. Here's how to indent cell content: 

Indenting Cell Content: 
 

1. *Select Cell(s)*: Click on the cell(s) whose content you want to indent. 

2. *Go to the "Format" Menu*: Once you've selected the cell(s), go to the "Format" menu at the top. 
 

3. *Choose "Text Wrapping"*: In the "Format" menu, hover over "Text wrapping" and select "Wrap." 
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4. *Indent the Content*: After enabling text wrapping, place the cursor at the beginning of the text 
you want to indent and press the Tab key on your keyboard. Each press of the Tab key will increase 
the level of indentation. 

Example: 
Let's say you have text in cell A1 that you want to indent: 

1. Click on cell A1 to select it. 
2. Go to the "Format" menu. 
3. Choose "Text wrapping" and select "Wrap." 
4. Place the cursor at the beginning of the text in cell A1 and press the Tab key to indent the content. 

Now, the text in cell A1 will be indented to create visual hierarchy or alignment within the cell. 
 
Indenting cell content can be useful for creating nested lists, outlining information, or organizing text in a 
structured manner within your Google Sheets. 

COUNT function 
In Google Sheets, the COUNT function is used to count the number of cells that contain numbers 
within a specified range. Here's how to use it: 

Syntax: 
=COUNT(value1, [value2, ...]) 
 

- value1: The first value or range of cells to count. 
- [value2, ...]: Additional values or ranges of cells to count (optional). 

Example: 
Let's say you have a range of cells A1:A10 containing numeric values, and you want to count how many 
cells contain numbers: 

1. Select the cell where you want the count result to appear. 
2. Enter the formula =COUNT(A1:A10). 

 
This will count the number of cells in the range A1:A10 that contain numbers and display the result in the 
selected cell. 

You can also use COUNT function to count specific numbers or conditions by providing multiple arguments. 
For example, =COUNT(A1:A10, ">5") will count the number of cells in the range A1:A10 that contain values 
greater than 5. 

CONCAT : 
Returns the concatenation of two values. Equivalent to the `&` operator. 

Sample Usage CONCAT("de","mystify") 
CONCAT(17,76) 

Syntax 
CONCAT(value1, value2) 
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• value1 - The value to which value2 will be appended. 
• value2 - The value to append to value1. 
 

 

Result Formula 

GoogleDocs =CONCAT("Google", "Docs") 

36 =CONCAT(3,6) 

Spreadsheet77 =CONCAT("Spreadsheet", 77) 

 
COUNTIF function 

In Google Sheets, the COUNTIF function is used to count the number of cells within a specified range that 
meet a certain condition. Here's how to use it: 
 
Syntax: 
=COUNTIF(range, criterion) 

- range: The range of cells you want to evaluate. 
- criterion: The condition that cells must meet to be counted. 

Example: 
Let's say you have a range of cells A1:A10 containing numbers, and you want to count how many of them 
are greater than 5: 
 

1. Select the cell where you want the count result to appear. 
2. Enter the formula =COUNTIF(A1:A10, ">5"). 

 
This will count the number of cells in the range A1:A10 that contain values greater than 5 and display the 
result in the selected cell. 
 
You can use various criteria with COUNTIF, such as equals to, not equal to, greater than, less than, etc., to 
count cells based on specific conditions. For example, =COUNTIF(B1:B10, "Apple") will count the number 
of cells in the range B1:B10 that contain the text "Apple". 



Page 20 of 44 

Pivot tables 
In Google Sheets, you can create pivot tables to summarize and analyze large datasets easily. Here's how 
to create a pivot table with an example: 

Example Dataset: 
Let's say you have a dataset containing sales data with columns for "Product", "Region", 
"Salesperson", and "Sales Amount". 

| Product | Region | Salesperson | Sales Amount | 
| | | | | 
 
 
 
 

 
Steps to Create a Pivot Table: 
 

1. *Select Data*: Highlight the entire dataset, including column headers. 
2. *Go to the "Data" Menu*: Click on the "Data" menu at the top. 
3. *Choose "Pivot table"*: Select "Pivot table" from the dropdown menu. 
4. *Configure Pivot Table*: 

- In the Pivot table editor on the right, drag and drop the fields you want to summarize into the 
"Rows", "Columns", and "Values" sections. 

- For example, you can drag "Region" into Rows, "Product" into Columns, and "Sales Amount" into 
Values. 
5. *Customize*: You can further customize the pivot table by changing aggregation methods (e.g., 
sum, average), sorting, formatting, and more. 

Example Pivot Table: 

| | Product A | Product B | Product C | 
| | | | | 
| North | 3000 | 2000 | 0 | 
| South | 800 | 1500 | 0 | 
| *Total| **3800* | *3500* | *0* | 
 
In this example, the pivot table summarizes sales amounts by product and region. You can see the total 
sales amounts for each product in each region, as well as the grand totals for each product across all 
regions. This provides a quick overview of sales performance across different regions and products. 

Add or edit pivot tables 

1. On your computer, open a spreadsheet in Google Sheets. 
2. Select the cells with source data you want to use. Important: Each column needs a header. 

3. In the menu at the top, click Insert Pivot table. Click the pivot table sheet, if it’s not already open. 
4. In the side panel, next to "Rows" or "Columns," click Add, then choose a value. 

     

| A | North | Alice | 1000 | 

| B | South | Bob | 1500 | 
| C | North | Alice | 1200 | 
| A | South | Bob | 800 | 
| B | North | Alice | 2000 | 

 

https://docs.google.com/spreadsheets/u/0/
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Calculated fields with SUM or a custom formula 

1. On your computer, open a spreadsheet in Google Sheets. 
2. Click the pop-up Edit button underneath the pivot table. 

3. In the side panel, next to "Values," click Add  click Calculated field. 
• Calculate a value with SUM: Next to “Summarize by,” click SUM. 
• Calculate a value with a custom formula: In the field that appears, enter a formula. Then, next to 

"Summarize by," click Custom. 
4. On the bottom right, click Add and the new column will appear. 

 

 

https://docs.google.com/spreadsheets/u/0/
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Vlookup : 
 

 
Vertical lookup. Returns the values in a data column at the position where a match was found in the search 
column. 

Sample Usage: VLOOKUP("Apple",table_name!fruit,table_name!price) 

VLOOKUP function 
In Google Sheets, the VLOOKUP function is used to search for a value in the first column of a range and 
return a value in the same row from a specified column. Here's how to use it: 
 
Syntax: 
=VLOOKUP(search_key, range, index, [is_sorted]) 

- search_key: The value to search for. 
- range: The range of cells where the search should be performed. The first column of the range 
should contain the search key, and the value to be returned should be in a column to the right. 
- index: The column index (starting from 1) of the value to be returned, relative to the first column in 
the range. 
- [is_sorted]: Optional. Set to TRUE if the first column in the range is sorted in ascending order, or 
FALSE if not. Defaults to TRUE if omitted. 

Example: Let's say you have a table with employee names in column A and their corresponding 
salaries in column B. You want to find the salary of an employee named "John". 
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1. *Enter the Formula*: In a cell where you want the result to appear, enter the following formula: 
=VLOOKUP("John", A:B, 2, FALSE) 

- search_key: "John" is the name of the employee you are searching for. 
- range: A:B specifies the range of cells where the search should be performed, with column A 

containing employee names and column B containing salaries. 
- index: 2 indicates that the function should return the value from the second column of the range 

(salary), which corresponds to the salary of the employee. 
- is_sorted: FALSE indicates that the data in the first column of the range is not sorted. 

2. *Press Enter*: Press Enter to execute the formula. The cell will display the salary of the employee 
named "John" if found. 

The VLOOKUP function is useful for quickly retrieving information from a table based on a lookup 
value, such as employee names, product IDs, or customer numbers. 

 

Data validation 
In Google Sheets, you can use data validation to set criteria for what can be entered into a cell. This 
ensures data integrity and consistency. Here's how to set up data validation with an example: 

Example Scenario: 
Let's say you have a column where users should enter numerical values representing product 
quantities. You want to ensure that users only enter values greater than or equal to 0. 

Steps to Set Up Data Validation: 
 

1. *Select Cells*: Click on the cell or range of cells where you want to apply data validation. For 
example, select the cells in column A where users will enter product quantities. 

2. *Go to the "Data" Menu*: Click on the "Data" menu at the top. 

3. *Choose "Data validation"*: In the "Data" menu, select "Data validation." 
 

4. *Configure Validation Criteria*: 
- In the "Data validation" dialog box, under the "Criteria" dropdown, choose "Number." 
- Select the desired condition from the "Criteria" dropdown (e.g., "Greater than or equal to"). 
- Enter the minimum value allowed (e.g., 0) in the field next to the dropdown. 

5. *Set Up Custom Error Message (Optional)*: 
- Optionally, you can enter a custom error message that will be displayed if users enter invalid data. 

This helps provide guidance on the expected input. 

6. *Apply Data Validation*: 
- Click "Save" to apply the data validation rules to the selected cells. 
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Example: 
1. Select the cells in column A where users will enter product quantities. 
2. Go to the "Data" menu. 
3. Choose "Data validation." 
4. In the "Data validation" dialog box: 

- Under the "Criteria" dropdown, choose "Number." 
- Select "Greater than or equal to" from the dropdown. 
- Enter "0" as the minimum value allowed. 
- Optionally, enter a custom error message such as "Please enter a number greater than 

or equal to 0." 
5. Click "Save" to apply the data validation rules. 

Setting up Data Validation: 

1. *Select Cells*: First, select the cell or range of cells where you want to apply data 
validation. For our example, let's select cells A1:A10 where users will enter product 
quantities. 

2. *Open Data Validation*: Go to the "Data" menu at the top of Google Sheets, then click 
on "Data validation." 

3. *Configure Criteria*: 
- Under the "Criteria" dropdown, select "Number" since we want to validate numerical 

values. 
- Choose the condition from the next dropdown. For our example, we'll choose 

"Greater than or equal to" to ensure values are 0 or higher. 
- Enter the minimum value allowed in the field next to the dropdown. In this case, it's 0. 

4. *Customize Error Message* (Optional): 
- If you want to provide a custom error message when users enter invalid data, check 

the "Show validation help text" box. 
- Enter your custom error message in the "Help text" field. For example, "Please enter a 

number greater than or equal to 0." 

5. *Save Validation*: 
- Click on "Save" to apply the data validation rules to the 

selected cells. Example: 

Let's use the steps above to set up data validation for product quantities in cells A1:A10. We 
want to ensure that users only enter values greater than or equal to 0. 

1. Select cells A1:A10. 
2. Go to the "Data" menu and choose "Data validation." 
3. Under "Criteria," choose "Number" and "Greater than or equal to." 
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4. Enter "0" as the minimum value. 
5. Optionally, enter a custom error message like "Please enter a number greater than or 

equal to 0." 
6. Click "Save" to apply the data validation. 
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UNIT-3: Multimedia Skill – Nimbus, Autocrat, Adobe Docu-sign 

 

Nimbus 

1. Introduction to Nimbus 

Nimbus is a powerful screen capturing and screen recording tool available as: 

• Browser extension (Chrome, Firefox, Edge) 

• Desktop application 

It is widely used for: 

• Taking screenshots 

• Recording screens 

• Creating tutorials and demonstrations 

• Online teaching and assignments 

• Technical documentation 

2. Features of Nimbus 

Nimbus provides the following major features: 

    Screenshot Capture 

• Full page screenshot 

• Visible part of screen 

• Selected area 

• Specific window 

    Screen Recording 

• Entire screen 

• Browser tab 

• Application window 

• Webcam + screen recording 

    Editing Tools 
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• Crop, resize 

• Draw shapes 

• Add arrows, text, blur 

• Highlight important areas 

    Cloud Storage 

• Save files to Nimbus cloud 

• Share links easily 

• Organize screenshots into folders 

3. Installing Nimbus 

Steps to Install Nimbus Extension 

1. Open Chrome Web Store 

2. Search Nimbus Screenshot & Screen Recorder 

3. Click Add to Chrome 

4. Grant required permissions 

Nimbus icon will appear near the address bar. 

4. Taking Screenshots Using Nimbus 

A. Capture Full Page 

1. Click Nimbus icon 

2. Select Entire Page 

3. Scrolls automatically and captures full webpage 

4. Opens editor for editing 

B. Capture Selected Area 

1. Click Nimbus icon 

2. Select Selected Area 

3. Drag mouse to select region 

4. Screenshot opens in editor 

C. Capture Visible Screen 
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• Captures only the visible portion of the webpage 

 

5. Editing Screenshots 

Nimbus provides an in-built editor: 

•          Draw shapes and lines 

•      Add text annotations 

•       Blur sensitive information 

•           Highlight important sections 

After editing: 

• Save locally 

• Upload to Nimbus cloud 

• Share via link 

6. Screen Recording with Nimbus 

Steps to Record Screen 

1. Click Nimbus icon 

2. Choose Record Screen 

3. Select: 

o Entire Screen 

o Browser Tab 

o Application Window 

4. Enable microphone or webcam (optional) 

5. Click Start Recording 

Stop Recording 

• Click Stop button 

• Video opens in editor 

• Save or share 
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7. Saving & Sharing Files 

Nimbus allows: 

• Save as PNG, JPG, MP4 

• Upload to Nimbus Cloud 

• Generate shareable links 

• Download to local system 

8. Uses of Nimbus 

• Online teaching & e-learning 

• Software tutorials 

• Assignment explanation 

• Bug reporting 

• Presentation preparation 

• Digital documentation 

 

9. Advantages of Nimbus 

✔ Easy to use 

✔ Powerful editing tools 

✔ Cloud sharing support 

✔ Free version available 

✔ Works directly in browser 

 

10. Limitations 

    Some features require paid version 

    Free version has recording time limits 

 

11. Conclusion 

Nimbus is an all-in-one screen capture and recording tool that helps users create professional 

screenshots and video tutorials with minimal effort. It is especially useful for students, 

educators, and IT professionals. 
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Autocrat  

1. Introduction to Autocrat 

Autocrat is a Google Workspace add-on used to automate document creation using data from 

Google Sheets. 

It is mainly used for: 

• Certificate generation 

• Bulk email sending 

• Report card generation 

• Invoice creation 

• Letter and notice distribution 

2. Features of Autocrat 

Autocrat provides the following key features: 

• Mail merge from Google Sheets 

• Automatic document generation 

• PDF or Google Doc output 

• Bulk email sending with attachments 

• Dynamic file naming 

• Folder organization in Google Drive 

• Scheduling and re-running jobs 

3. Installing Autocrat 

Steps to Install 

1. Open Google Sheets 

2. Click Extensions → Add-ons → Get add-ons 

3. Search Autocrat 

4. Click Install 

5. Grant permissions 

Autocrat will now appear under Extensions. 
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4. Preparing Data in Google Sheets 

Create a spreadsheet with column headers such as: 

• Name 

• Email 

• Course 

• Certificate ID 

• Date 

Each row represents one recipient. 

 

5. Creating a Template in Google Docs 

1. Open Google Docs 

2. Create a certificate or document 

3. Insert placeholders using << >> 

Example Placeholders 

<<Name>> 

<<Course>> 

<<Date>> 

These placeholders must exactly match column headers in Google Sheets. 

 

6. Using Autocrat (Step-by-Step) 

Step 1: Launch Autocrat 

• Open Google Sheet 

• Click Extensions → Autocrat → Launch 

Step 2: Select Template 

• Choose your Google Docs template 

Step 3: Map Template Fields 
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• Autocrat automatically maps placeholders to sheet columns 

Step 4: Output Settings 

• Choose output type: 

o Google Doc 

o PDF 

• Choose destination folder 

Step 5: File Naming 

Example: 

Certificate_<<Name>>_<<Course>> 

Step 6: Email Settings 

• Enable email sending 

• Select email column 

• Write subject and message 

• Attach generated file 

Step 7: Run Job 

• Click Run Job 

• Documents are generated automatically 

 

7. Scheduling & Re-Running Jobs 

• Run on form submit 

• Re-run for new rows only 

• Manually re-run entire sheet 

8. Applications of Autocrat 

• Certificate distribution 

• Bulk email sending 

• Student progress reports 

• Appointment letters 
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• Offer letters 

• Event participation certificates 

9. Advantages of Autocrat 

✔ Saves time 

✔ No coding required 

✔ Easy integration with Google Workspace 

✔ Accurate bulk document creation 

✔ Free to use 

10. Limitations 

    Requires Google account 

    Depends on internet 

    Formatting errors if placeholders mismatch 

11. Conclusion 

Autocrat is a powerful automation tool that simplifies document generation and bulk emailing. 

It is widely used in educational institutions and organizations for managing large-scale 

documentation efficiently 

Adobe DocuSign 

Adobe DocuSign (commonly referred to as Adobe Acrobat Sign / DocuSign e-Signature) is a 

digital signing tool used to electronically sign documents and send them for signatures 

securely. 

It eliminates the need for: 

• Printing documents 

• Physical signatures 

• Scanning and emailing 

2. Key Features of Adobe DocuSign 

• Electronic signatures (legally valid) 

• Multi-recipient signing workflow 

• Secure document tracking 

• Audit trail and timestamps 
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• Cloud storage integration 

• Mobile and web access 

• PDF document support 

3. Where Adobe DocuSign Is Used 

• Educational institutions 

• Government offices 

• Corporate organizations 

• Banks and legal firms 

• HR departments 

• Online approvals 

4. Creating an Adobe DocuSign Account 

Steps 

1. Visit Adobe Acrobat Sign / DocuSign website 

2. Click Sign Up 

3. Register using email or Google account 

4. Verify email 

5. Signing a Document Yourself 

Steps 

1. Open Adobe DocuSign 

2. Click Upload Document 

3. Select PDF/Word file 

4. Click Sign 

5. Draw / Type / Upload signature 

6. Place signature in document 

7. Click Finish 

The signed document can be: 

• Downloaded 
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• Shared via email 

• Stored in cloud 

6. Sending Documents for Signature 

Steps 

1. Click Send for Signature 

2. Upload document 

3. Add recipient email addresses 

4. Set signing order (if required) 

5. Add signature fields 

6. Click Send 

Recipients receive an email link to sign. 

7. Tracking Document Status 

You can track: 

• Sent 

• Viewed 

• Signed 

• Pending 

• Completed 

Notifications are sent at every stage. 

8. Security & Legal Validity 

Adobe DocuSign provides: 

• Encrypted data transfer 

• Tamper-proof documents 

• Audit trail 

• Timestamped signatures 

E-signatures are legally valid under: 

• IT Act, 2000 (India) 
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• ESIGN Act 

• eIDAS Regulation 

9. Advantages of Adobe DocuSign 

✔ Fast and paperless 

✔ Secure and legally valid 

✔ Easy to use 

✔ Saves time and cost 

✔ Environment-friendly 

10. Limitations 

    Advanced features require paid plan 

    Internet connection required 

    Limited free signatures per month 

11. Comparison: Manual vs Adobe DocuSign 

Feature Manual Signing Adobe DocuSign 

Time Slow Instant 

Cost High Low 

Security Low High 

Tracking No Yes 

Storage Physical Digital 

 

12. Conclusion 

Adobe DocuSign is a reliable and secure e-signature solution that simplifies document signing 

workflows. It is highly useful in education, corporate, and government sectors 
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UNIT-4: Web Conferencing Skills – Google Meet & Zoom 

1. Introduction 

Web conferencing tools enable people to communicate, collaborate, and conduct meetings 

online using audio, video, and screen sharing. These tools are widely used for online classes, 

webinars, meetings, and training programs. 

Two popular web conferencing platforms are: 

• Google Meet 

• Zoom 

2. Objectives of Web Conferencing 

The main objectives are: 

• To enable real-time online communication 

• To conduct virtual classes and meetings 

• To share screens, presentations, and documents 

• To collaborate remotely 

• To reduce travel time and cost 

3. Google Meet 

3.1 Introduction to Google Meet 

Google Meet is a video conferencing service developed by Google. It integrates with Gmail, 

Google Calendar, and Google Classroom. 

3.2 Features of Google Meet 

• Video and audio conferencing 

• Screen sharing 

• Chat messaging 

• Meeting recording (paid accounts) 

• Google Calendar integration 

• Live captions 

• Participant controls 

3.3 Google Meet – Demo (Step-by-Step) 
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A. Starting a Meeting 

1. Open meet.google.com 

2. Click New Meeting 

3. Choose: 

o Create instant meeting 

o Schedule in Google Calendar 

4. Copy meeting link and share 

B. Joining a Meeting 

1. Open meeting link 

2. Enter meeting code 

3. Click Join Now 

C. Screen Sharing 

1. Click Present Now 

2. Choose: 

o Entire Screen 

o Window 

o Chrome Tab 

D. Chat & Controls 

• Use Chat for messages 

• Turn Mic/Camera ON/OFF 

• Remove or mute participants (host) 

4. Zoom 

4.1 Introduction to Zoom 

Zoom is a widely used cloud-based video conferencing platform known for its advanced 

meeting controls and large participant capacity. 

 

4.2 Functionality of Zoom 
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Zoom offers the following core functionalities: 

• HD video and audio 

• Screen sharing 

• Meeting recording 

• Chat (private & group) 

• Virtual backgrounds 

• Host and co-host controls 

• Polling and reactions 

4.3 Breakout Rooms in Zoom 

Breakout Rooms allow hosts to divide participants into smaller groups for discussions or 

activities. 

Steps to Create Breakout Rooms 

1. Start Zoom meeting 

2. Click Breakout Rooms 

3. Choose number of rooms 

4. Assign participants automatically or manually 

5. Click Open Rooms 

Uses of Breakout Rooms 

• Group discussions 

• Team activities 

• Classroom assignments 

• Brainstorming sessions 

4.4 Live Streaming in Zoom 

Zoom supports live streaming to platforms such as: 

• YouTube 

• Facebook Live 

• Custom RTMP servers 
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Steps for Live Streaming 

1. Start Zoom meeting 

2. Click More (⋯) 

3. Select Live on YouTube / Facebook 

4. Sign in to streaming platform 

5. Start live broadcast 

5. Comparison: Google Meet vs Zoom 

Feature Google Meet Zoom 

Ease of use Very easy Easy 

Breakout rooms Limited Advanced 

Live streaming Limited Supported 

Integration Google Workspace Multiple platforms 

Free plan limit 60 minutes 40 minutes 

 

6. Advantages of Web Conferencing 

✔ Remote learning and meetings 

✔ Time and cost saving 

✔ Global connectivity 

✔ Easy collaboration 

✔ Environment friendly 

7. Conclusion 

Web conferencing tools like Google Meet and Zoom play a vital role in online education, 

corporate meetings, and virtual events. Mastering these tools enhances digital communication 

and collaboration skills. 
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UNIT-5: Sending Bulk SMS 

1. Introduction 

Bulk messaging refers to the process of sending a single message to a large number of recipients 

simultaneously. It is widely used by educational institutions, businesses, and organizations for 

alerts, promotions, notifications, and communication. 

Bulk communication can be done through: 

• SMS 

• Email 

• WhatsApp 

2. Introduction to SMS Protocol 

2.1 What is SMS? 

SMS (Short Message Service) is a communication protocol that allows the exchange of short 

text messages (up to 160 characters) between mobile devices over cellular networks. 

2.2 How SMS Protocol Works 

1. Message is composed by sender 

2. Message is sent to SMS Center (SMSC) 

3. SMSC forwards the message to recipient’s mobile network 

4. Message is delivered to recipient device 

2.3 Types of SMS 

• Transactional SMS – OTPs, alerts, confirmations 

• Promotional SMS – advertisements, offers 

• Service SMS – notifications, updates 

2.4 Advantages of SMS Protocol 

✔ Works without internet 

✔ High open rate 

✔ Fast delivery 

✔ Supported by all mobile phones 

 



Page 42 of 44 

 

3. Customized Service to Send Out Email 

3.1 What is Bulk Emailing? 

Bulk emailing is the process of sending customized emails to multiple recipients using 

automated tools. 

3.2 Features of Customized Email Services 

• Personalization using recipient name 

• Email templates 

• Mail merge functionality 

• Attachments support 

• Scheduled delivery 

• Tracking (open/click reports) 

3.3 Tools Used for Bulk Email 

• Gmail Mail Merge 

• Google Sheets + Autocrat 

• Mailchimp 

• SendGrid 

3.4 Steps for Sending Customized Bulk Email 

1. Prepare email list in spreadsheet 

2. Create email template 

3. Insert dynamic fields (Name, ID, etc.) 

4. Use mail merge tool 

5. Send emails in bulk 

4. Customized Service to Send SMS in Bulk 

4.1 Bulk SMS Services 

Bulk SMS services use API gateways to send messages to thousands of numbers at once. 

4.2 Features of Bulk SMS 
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• Sender ID customization 

• Message templates 

• Contact grouping 

• Scheduling 

• Delivery reports 

4.3 Steps to Send Bulk SMS 

1. Register with bulk SMS service provider 

2. Upload contact list 

3. Compose message 

4. Select SMS type (Transactional/Promotional) 

5. Send or schedule message 

5. Customized Service to Send WhatsApp Messages in Bulk 

5.1 WhatsApp Bulk Messaging 

WhatsApp bulk messaging uses WhatsApp Business API to send messages legally and securely. 

5.2 Features of WhatsApp Bulk Messaging 

• Rich media (images, videos, PDFs) 

• Personalization 

• High engagement 

• Automated replies 

• Message templates approval 

5.3 Steps to Send Bulk WhatsApp Messages 

1. Register for WhatsApp Business API 

2. Get message templates approved 

3. Upload contact list 

4. Customize message fields 

5. Send messages 
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6. Comparison: Email vs SMS vs WhatsApp 

Feature Email SMS WhatsApp 

Internet Required Yes No Yes 

Message Length Long Short Medium 

Open Rate Medium High Very High 

Media Support Yes No Yes 

7. Applications of Bulk Messaging 

• Educational notifications 

• Exam alerts 

• Event promotions 

• Marketing campaigns 

• OTP verification 

• Emergency alerts 

8. Advantages of Bulk Messaging 

✔ Fast communication 

✔ Cost-effective 

✔ Personalized messaging 

✔ Wide reach 

✔ Automation support 

9. Limitations 

    Message spam restrictions 

    Regulatory compliance required 

    Internet dependency (Email/WhatsApp) 

 

10. Conclusion 

Sending bulk SMS, Email, and WhatsApp messages is an effective digital communication strategy 

that enables organizations to reach a large audience quickly and efficiently while maintaining 

personalization. 


